VPS参考测评推荐
专注分享VPS主机优惠信息
阿里云618年中促销

便宜国外vps论坛_小白一枚给大家说一下用ros路由作为国内中转教程

华为云
主机参考:服务器测评参考推荐网,专注分享服务器优惠信息!如果您想在本站投放您的广告,点此直达!如果您不想付费,您也可以免费投稿您的产品信息,点此直达联系我们
部分文章发布时间较久远,可能存在未知因素,购买时建议在本博客搜索商家名称,可查看相关文章充分了解商家!若非中文页面可使用谷歌浏览器同步翻译!跑路不诚信商家列表

ros路由相信大佬级别很简单,对我们这群小白还是有点难度的,接触ros路由也有1年了,基本都是作为国内NAT小鸡中转用的,今天看有人需要就简单的说明一下,供MJJ们也能用上,减少折腾吧。
步骤一说:去ros官网注册个试用账号,不登录的话会被限速带宽1M,虽然试用一个月,但是到期后还是维持试用时期设置配置。ROS路由官网:https://mikrotik.com/client
步骤二说:把国内小鸡DD成ROS路由,这里感谢方总的教学,详细教学出于一位大佬,我只是搬运工。
dd前 使用fdisklu 注意查看下自己VPS的 磁盘路径  并不是所有VPS 都是 /dev/vda  这个路径   有些可能是   /dev/sda  /dev/xvda
执行说:fdisk -ul chr.img可以查看chr.img信息    查找 start 值 使用开始值 * 512  算出柱面位置 默认扇区大小为512  挂载时注意修改这个
注意自己的网卡名字,有些VPS并不是eth0 需要修改脚本内的网卡名字与其对应
如果缺少 wget   使用命令说:  yum install wget -y
脚本只适应于CentOS 6.9  7.X  测试通过~
通用单网卡方案         (适应于绝大多数VPS)
wget https://download.mikrotik.com/routeros/6.45.8/chr-6.45.8.img.zip -O chr.img.zip &&
gunzipc chr.img.zip > chr.img &&
mounto loop,offset=512 chr.img /mnt &&
ADDR0=`ip addr show eth0 | grep global | cut -d’ ‘ –f 6 | head –n 1` &&
GATE0=`ip route list | grep default | cut -d’ ‘ –f 3` &&
mkdirp /mnt/rw &&
echo “/ip address add address=$ADDR0 interface=[/interface ethernet find where name=ether1]
/ip route add gateway=$GATE0
” > /mnt/rw/autorun.scr &&
umount /mnt &&
echo u > /proc/sysrqtrigger &&
dd if=chr.img bs=1024 of=/dev/sda && reboot
阿里云经典网卡 (注意分清 内外 网卡)

                           缺省网关
default via 202.5.30.254 dev eth0 proto static metric 100
10.0.0.0/8 dev eth1 proto kernel scope link src 10.0.122.21 metric 101              目标地址  <>  网关
202.5.30.0/24 dev eth0 proto kernel scope link src 202.5.30.231 metric 100          目标地址  <>  网关

wget https://download.mikrotik.com/routeros/6.45.8/chr-6.45.8.img.zip -O chr.img.zip
gunzipc chr.img.zip > chr.img
mounto loop,offset=512 chr.img /mnt
ADDR0=`ip addr show eth0 | grep global | cut -d’ ‘ –f 6 | head –n 1`                       
ADDR1=`ip addr show eth1 | grep global | cut -d’ ‘ –f 6 | head –n 1`                       
GATE0=`ip route list | grep default | cut -d’ ‘ –f 3`
GATE1=`ip route list | grep ‘10.0.0.0/8′ | cut -d’ ‘ –f 9`
GATE2=`ip route list | grep ‘202.5.30.0/24′ | cut -d’ ‘ –f 9`
mkdirp /mnt/rw

echo “/ip address add address=$ADDR0 interface=[/interface ethernet find where name=ether1]
/ip address add address=$ADDR1 interface=[/interface ethernet find where name=ether2]
/ip route add gateway=$GATE0
/ip route add dstaddress=10.0.0.0/8 gateway=$GATE1
” > /mnt/rw/autorun.scr

umount /mnt
echo u > /proc/sysrqtrigger
dd if=chr.img bs=1024 of=/dev/vda && reboot

一款网卡的样本        (注意分清 内外 网卡)
196.10.68.0/24 dev eth0  proto kernel  scope link  src 196.10.68.24
169.254.0.0/16 dev eth0  scope link  metric 1002
169.254.0.0/16 dev eth1  scope link  metric 1003
10.0.0.0/8 dev eth1  proto kernel  scope link  src 10.0.87.152
default via 196.10.68.1 dev eth0

wget https://download.mikrotik.com/routeros/6.45.8/chr-6.45.8.img.zip -O chr.img.zip
gunzipc chr.img.zip > chr.img
mounto loop,offset=512 chr.img /mnt
ADDR0=`ip addr show eth0 | grep global | cut -d’ ‘ –f 6 | head –n 1`                       
ADDR1=`ip addr show eth1 | grep global | cut -d’ ‘ –f 6 | head –n 1`                       
GATE0=`ip route list | grep default | cut -d’ ‘ –f 3`
GATE1=`ip route list | grep ‘10.0.0.0/8′ | cut -d’ ‘ –f 9`
mkdirp /mnt/rw

echo “/ip address add address=$ADDR0 interface=[/interface ethernet find where name=ether1]
/ip address add address=$ADDR1 interface=[/interface ethernet find where name=ether2]
/ip route add gateway=$GATE0
/ip route add dstaddress=10.0.0.0/8 gateway=$GATE1
” > /mnt/rw/autorun.scr

umount /mnt
echo u > /proc/sysrqtrigger
dd if=chr.img bs=1024 of=/dev/vda && reboot

常见问题说:
有些D完死活启不动连不上 是因为UEFI的缘故,跟脚本无关 请改用 ROS7.0Beta 版本 支持UEFI启动
wget https://download.mikrotik.com/routeros/7.0beta5/chr-7.0beta5.img.zip -O chr.img.zip

aws Cloud DD完以后 要手动关机,再开机即可连接

步骤三说:一般NAT小鸡DD完ros后会自动设置网络这些,只需要重启机器,然后网页打开NAT的IP:SSH端口号说:例如23.23.23.23:51000     这里的51000就是平时22端口被NAT小鸡转发端口数字登录ros路由管理界面
第二个方法,也是最好用,最常见的,用winbox登录ros路由,在登录需要重新映射winbox端口为NAT小鸡给我指定的IP端口段内,例如NAT端口段51000-51020,因为51000被作为SSH使用了,那就用51001作为winbox端口,映射方法连接NAT小鸡的VNC,输入ros登录名说:admin  密码为空
进入控制台输入说:/ip service set winbox port=映射端口   这样就可以用NAT小鸡公共IP+51001端口登录winbox了,登录winbox后找到system-License菜单输入开始注册好的ros试用账号,给予授权开启试用之路
便宜国外vps论坛_小白一枚给大家说一下用ros路由作为国内中转教程-主机参考

步骤四说:设置中转端口转发, IP-Firewall,  选择NAT,点击+号  设置如图说:
便宜国外vps论坛_小白一枚给大家说一下用ros路由作为国内中转教程-主机参考

便宜国外vps论坛_小白一枚给大家说一下用ros路由作为国内中转教程-主机参考

便宜国外vps论坛_小白一枚给大家说一下用ros路由作为国内中转教程-主机参考

这是第一条规则设置好后点击OK保存

第二条规则现在添加国外VPS的IP和端口

便宜国外vps论坛_小白一枚给大家说一下用ros路由作为国内中转教程-主机参考

便宜国外vps论坛_小白一枚给大家说一下用ros路由作为国内中转教程-主机参考

最后点击OK,就完全搞定了,修改相应的中转IP和端口开启ros路由中转之旅吧。

便宜国外vps论坛_小白一枚给大家说一下用ros路由作为国内中转教程-主机参考

最后说明一下,如果这篇教程有任何违规问题,还请管理删除,再次感谢管理

各路大神回复说:

注册说: 可以了,先mark

zaojiapai说: 战略性mark

laogui说: 战略性mark

aipage说: 官网试用的license不是60天内不限制么? 超过60天还能用?

Xhvai110说: 必须可以,维持试用时期的配置,已经有说明了

杜甫说: 可以,先mark一下,后续等大佬操作

zaojiapai说: 只是基础性东西,后面的ros玩隧道就不公布了。毕竟这隧道涉及到一些大佬商家的伪IPLC利益。个人用完全可以了,不用考虑那么多了。

Squidward说: mark

zaojiapai说: 文章不错,战略性mark一下

注册说: mark一下  之前我记得chr授权可以x86的那种?回去研究研究

注册说: VPS路由器系统。刷了后。能干嘛呢》??

星际旅者说: 战略性mark

飘云说: 这次出了更完整的教程了,必须赞一个,过段时间把一个kvmnat ddros

主机参考zhujicankao.com_收集国内VPSVPS测评主机测评,云服务器虚拟主机,独立服务器国内外服务器,高性价比建站主机相关优惠信息
详细介绍和测评国外VPS主机,云服务器,国外服务器,国外主机的相关优惠信息,商家背景,网络带宽等等,也是目前国内最好的主机云服务器VPS参考测评资讯优惠信息分享平台

打赏
转载请注明原文链接:主机参考 » 便宜国外vps论坛_小白一枚给大家说一下用ros路由作为国内中转教程
主机参考仅做资料收集,不对商家任何信息及交易做信用担保,购买前请注意风险,有交易纠纷请自行解决!

评论 抢沙发